Sunday, July 10, 2011

Error: Device 0 (vif) could not be connected. Hotplug scripts not working xen restart solved

You may get this error while restarting the xen vps or virtual server.
It wont start if you are restarting it from front end like solusvm.

So start form the backend.
[root@xen ~]# xm create /home/xen/vm130/vm130.cfg
Using config file "/home/xen/vm130/vm130.cfg".
Error: Device 0 (vif) could not be connected. Hotplug scripts not working.

If you get any hotplug error then check the hotplug error log.
[root@xen ~]#  tail /var/log/xen/xen-hotplug.log
Nothing to flush.

can't add vifvm130.0 to bridge eth0: Operation not supported
Nothing to flush.
can't add vifvm130.0 to bridge eth0: Operation not supported
Nothing to flush.
can't add vifvm130.0 to bridge eth0: Operation not supported
[root@xen ~]#

Now you know the error. Open the configuration file.
vi /home/xen/vm130/vm130.cfg

See the bridge device name was given
vif        = ['type=ioemu, ip=178.162.239.188, vifname=vifvm130.0, mac=00:16:3e:50:e1:8c, bridge=eth0']

Change it to as follows.
vif        = ['type=ioemu, ip=178.162.239.188, vifname=vifvm130.0, mac=00:16:3e:50:e1:8c']
Now it works. Have fun.

(network.c.336) SSL: error:00000000:lib(0):func(0):reason(0) Kloxo restart error solved

Error :
[root@test /]# /etc/init.d/kloxo restart
Stopping kloxo: Waiting for the process to die.....
Stopped kloxo
Starting kloxo: 11
2011-07-09 19:01:30: (network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)
mysqld (pid 1557) is running...
Started kloxo
[root@test /]#

Solution

Remove the openssl with nodeps option

rpm -e --nodeps openssl

Download lower version
http://download.clearfoundation.com/clearos/enterprise/5.1/System/RPMS/openssl-0.9.8e-12.el5_4.1.i686.rpm
rpm -ivh openssl-0.9.8e-12.el5_4.1.i686.rpm

Now restart Kloxo
/etc/init.d/kloxo restart

[root@test /]# /etc/init.d/kloxo restart
Stopping kloxo: ../bin/common/function.sh: line 28:  7239 Terminated              $__path_server_exe $string >/dev/null 2>&1
Waiting for the process to die.....
Stopped kloxo
Starting kloxo: 11
mysqld (pid 1557) is running...
Started kloxo
[root@test /]#